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Section 4 
 

Linking and Embedding 

By the end of this Section you should be able to: 

Insert Text Slides 
Link to Documents 
Link to Worksheets 

Link to Charts 
Link to Images 

Update and Edit Links 
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Exercise 30 - Inserting Text Slides 
Guidelines: 

Individual sections of text can be imported into a PowerPoint presentation from 
word processing applications most easily by using Copy and Paste. However, 
if a document is created with the correct outline already set up, it can be 
imported using a command in PowerPoint, which will create new slides directly. 

Actions: 

1. Open the word processing application Word and open the file 
Welcome.docx, which is included with the supplied PowerPoint files. 
Make sure Outline View, , is selected. 

2. Examine the text; it has been formatted at different levels.  

 

3. When imported into PowerPoint, the highest level text will be translated 
into slide titles, the next level into 1st level bullet points, and so on. Close 
the document and close Word. 

4. In PowerPoint create a new blank presentation. On the Title Slide add 
Welcome as the title text and your organisation name as the subtitle text. 

5. Apply a design theme of Solstice. 

6. To import the outline, select the Home tab and drop down the New Slide 
options. Select Slides from Outline. Look in the supplied data files folder 
and select All Outlines from Files of type. 

7. Select the file Welcome and click the Insert button, . 

8. Three new slides are created from the outline file. Compare their structure 
with the original file layout. 

 

9. Save the presentation as links and leave it open. 
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Exercise 31 - Linking to a Document 
Guidelines: 

Objects on a slide can be linked to external data from a variety of other 
applications. Linking an object means that if its source data is changed, those 
changes can be reflected in the object in the presentation. It also means that 
the source data can be opened in its own application directly from PowerPoint.  

Actions: 

1. At the end of the current presentation create a new Title Only slide and 
add the title Products. 

2. To create a link, select the Insert tab, then Object and the Create from 
file option. 

3. Click Browse and locate the supplied PowerPoint data files. Select the 
Products file and click OK. 

 

4. In the Insert Object dialog box, check Link. 

5. Click OK to insert the document as a linked object, then save the 
presentation. 

6. The text cannot be altered directly on the slide. To amend the text, double 
click the object. Word starts and opens the source document. 

7. In Word, format the Product Range heading as Bold Italic. 

8. Save the document and close Word. Notice that the slide content has 
changed to match the changes to the source document. 

Note: In this example the presentation was open when the source object was 
being changed. The situation where the presentation is not open will be 
covered in a later exercise. 

9. Leave the presentation open. 



Open Learning PowerPoint Advanced 

© CiA Training Ltd 2011 57 PowerPoint 2010 

Exercise 32 - Linking to a Worksheet 
Guidelines: 

A link can be created from a slide to a range of data on a worksheet. As before 
the data cannot be amended from PowerPoint, but only by amending the 
source data in its original application (Excel). 

Actions: 

1. At the end of the current presentation create a new Title Only slide and 
add the title Performance. 

2. Start Excel and open the workbook Sales from the data files. 

3. Display the Data sheet and click and drag to select the range B3:D15. 
This range has already been given the name Range. 

4. Copy the range then switch back to PowerPoint. 

5. To create a link to the range, from the Home tab, select the Paste drop 
down options and then Paste Special. 

6. Select the Paste link option and click OK. 

7. The range selected from the spreadsheet is now linked to the 
presentation. Enlarge the range object by dragging a corner handle then 
save the presentation. 

 

8. Although the data cannot be amended on the slide, the whole object can 
be formatted. Right click the object and select Format Object. Change 
the Fill Color to light blue and click Close. 

Note: The link can also be created by using the Object button on the Insert tab 
as used in the last exercise. The part of the spreadsheet that was last 
selected will be used as the object. 

9. Double click the object to open it in Excel, then leave Excel open for the 
next exercise. 
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Exercise 33 - Linking to a Chart 
Guidelines: 

Rather than create a chart in PowerPoint, if a suitable one already exists within 
a workbook you can import it or create a link to it. 

Actions:  

1. With the Sales workbook open in Excel, click on the 2009 sheet tab to 
open it. Click on the chart and then click Copy, . 

2. Switch to PowerPoint and insert two new Title Only slides at the end of 
the Link presentation. 

3. Add the title Linked Chart to the first of the new slides and Embedded 
Chart to the other. 

4. Click in the main area of the Embedded Chart slide and select Paste and 
then Paste Special. 

 

5. With Paste selected, click OK. The chart is pasted into the presentation, 
with its associated data. It is embedded, i.e. no longer linked to the 
original workbook. Resize to make it fit the slide. 

6. Click in the main area of the Linked Chart slide and select Paste and 
then Paste Special again. 

7. This time select Paste link and click OK. The chart is pasted into the 
presentation as a link to the original workbook. 

8. Double click the chart on the Linked Chart slide. The original workbook is 
opened in Excel. Close Excel without saving any changes. 

Note: The chart and data can be amended on the Embedded Chart slide by 
clicking the Edit Data button on the Chart Tools Design tab. 

9. Leave the presentation open. 
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Exercise 34 - Linking to an Image 
Guidelines: 

Links to images can also be added to a presentation. If the original image is 
edited in any way, the changes are reflected in the linked PowerPoint object. 

Actions: 

1. At the end of the links presentation create another Title Only slide. 

2. Name it Linked Image. 

3. To create a link to an image file, from the Insert tab, select Picture. 

4. Select the location of the supplied data folder and select the file cat.gif file 
from the contents. 

5. Click the drop down arrow on the Insert button. 

 

6. Click the Link to File option. The linked graphic is placed in the 
presentation and can be manipulated like any inserted object. 

 

Note: Links to images are handled differently to other links. Double clicking the 
image will not open it in any application. 

7. Save the links presentation and close it. 

8. Close PowerPoint. 
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Exercise 35 - Updating Linked Data 
Guidelines: 

The default when creating links is for them to have the automatic update option 
set. Whenever a presentation containing links is opened, you will always be 
prompted to update the data from automatic links. If the option is accepted, all 
automatic update linked objects within the presentation will be updated with the 
current versions of the source data. If not, they will be left unchanged. 

Actions: 

1. Open the workbook Sales in Excel. 

2. Select the worksheet Data and change the number of licenses sold in 
January to 20. 

3. Select the worksheet 2009 and right click on the Plot Area. Select 
Format Plot Area from the shortcut menu. 

4. From Gradient fill, select a Preset color effect of Daybreak. 

 

5. Click Close. 

6. Save the workbook and close Excel. 

7. Open Word and open the document Products. At the end of the list add a 
new product e-Citizen, with the same formatting as the existing content. 

continued over 
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Exercise 35 - Continued 
8. Save the document with the same name and close Word. 

9. Open Microsoft Paint (All Programs | Accessories | Paint from the Start 
menu) and open the image cat.gif from the supplied data files. 
Remember to specify All Files in the Files of type box. 

10. Use the Fill with color tool, , to change the colour of the cat from 
black to blue (select the colour from the palette at the top of the window). 

11. Save the image and close the application. 

12. Start PowerPoint open the presentation links - a prompt appears: 

 

13. Read the text in the message box then click Update Links. The process 
may take a few moments. 

14. Check the Products slide (slide 5). The new text is shown. 

15. Check the Performance slide (slide 6). The new data for January is 
shown. 

16. Check the Linked Chart slide (slide 7). The new data and chart 
background is shown. 

Note: A linked chart can also be updated by right clicking on it and selecting 
Update Link from the shortcut menu. 

17. Check the Embedded Chart slide (slide 8). No changes are shown 
because this object is not linked, it is embedded. 

Note: An embedded chart can also be updated by clicking the Refresh Data 
button found in the Data group of Chart Tools Design tab. 

18. Check the Linked Image slide (slide 9). 

19. Save the presentation and leave it open for the next exercise. 
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Exercise 36 - Editing Links 
Guidelines: 

Once links have been created in a presentation, they can be amended, 
updated or broken at any time. 

Actions: 

1. Select the File tab. From the list select Info and then Edit Links to Files, 
found in the Properties panel at the bottom right of the screen. All links in 
the presentation are shown.  

 

2. Click on the Document link (to Products). This is currently an Automatic 
link. Click the Manual option at the bottom of the dialog box. 

3. Click Close on the dialog box, then save the presentation and close it.  

4. Open Word and open the document Products. Delete the line showing 
Trainer's Packs.  

5. Save the document with the same name and close Word. 

6. In PowerPoint, open the links presentation, selecting the Update Links 
option when prompted. 

7. Check the Products slide (slide 5). The text has not been amended 
automatically, the update must be requested manually. 

8. Select the File tab, select Info and then Edit Links to Files. 

9. Click on the link to the Products document and click Update Now. The 
text is amended to match the source. Click Close and the Home tab to 
see the slide. 

Note: In the Links dialog box,  allows the link to be redirected to a 
new source and  removes the link from that object. 

10. Save the presentation and close it. 
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Exercise 37 - Revision: Linking and Embedding 
1. Open the Section4 presentation. 

2. Insert text from the Facilities.docx file which is included with the supplied 
data files, to create 3 new slides at the end of the presentation. 

3. Insert a Title Only slide at the end of the presentation and add a title of 
Price List. 

4. Start Excel and open the spreadsheet Prices.xlsx and select the range 
A1:D4. Insert this range on to the new slide, so that the data on the slide 
is linked to the data in the spreadsheet. 

5. Insert another Title Only slide at the end of the presentation and add a 
title of Occupancy. 

6. Open the spreadsheet Forest.xlsx and insert the chart from the Chart 
sheet on to the new slide so that the data on the slide is linked to the data 
in the spreadsheet. 

7. Save the presentation as revision37 and close it. 

8. In the Prices spreadsheet, increase the prices in the Comfort range by 
£10, then save and close the file. 

9. In the Forest spreadsheet, change the colour of the Chart Walls to 
another suitable colour, then save and close the file. 

10. Close Excel. 

11. In PowerPoint, open the revision37 presentation so that the updated data 
is shown. 

12. Edit the links in the presentation. Make the link to the Prices data a 
Manually updated link. 

13. Break the link to the chart data so that the chart on the slide will no longer 
be affected by changes in the original spreadsheet. 

14. Save and close the presentation. 

Note: An example of slides added in this exercise can be found in the Answers 
section at the end of the guide. 


